Author Topic: MySQL Problem On WAMP  (Read 3385 times)

Orogan

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
MySQL Problem On WAMP
« on: October 27, 2009, 04:04:34 pm »
When I go to install 1.1.1.+nb I get this error:

Quote
Requirements not sufficient

You need Mysql 5.0 to install this version. Please upgrade from your existing Mysql version mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $.

I am using WAMP 2 however I have MySQL version 5.1.36 

Nightborn

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
  • Karma: +20/-0
    • View Profile
    • Shinobilegends
Re: MySQL Problem On WAMP
« Reply #1 on: October 29, 2009, 05:53:09 pm »
It seems the Windows System have a different reporting style *sigh*.

Go to installer.php and edit out the lines with the check

Code: [Select]
21 } elseif (version_compare(mysql_get_client_info(), '5.0.3') < 0) {
 22         $requirements_met=false;
 23         $mysql_met=false;

Then Windows (again) behaves disaccording to rules -.-

It should be fixed, but it won't be easy and it won't be fast. If you want
to help - wonderful. But keep in mind that it will take months of wading
through the ugliest code we have in the tree. If you've got a weak stomach -
stay out. I've been there and it's not a nice place.

   - Al Viro