Author Topic: Admin-account insert failure  (Read 5475 times)

Harthas

  • Guest
Admin-account insert failure
« on: April 05, 2008, 09:04:09 pm »
The Admin-Account won't be inserted at the end of the installation.
Will look it over in an couple of hours

Nightborn

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
  • Karma: +20/-0
    • View Profile
    • Shinobilegends
Re: Admin-account insert failure
« Reply #1 on: April 05, 2008, 09:12:36 pm »
I need more information on that.

Remember: plain mysql 5 *necessary*
It should be fixed, but it won't be easy and it won't be fast. If you want
to help - wonderful. But keep in mind that it will take months of wading
through the ugliest code we have in the tree. If you've got a weak stomach -
stay out. I've been there and it's not a nice place.

   - Al Viro

Nightborn

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
  • Karma: +20/-0
    • View Profile
    • Shinobilegends
Re: Admin-account insert failure
« Reply #2 on: April 05, 2008, 09:45:37 pm »
Fixed.

Re-download the version.
(forgot to add to the check that you MAY be in the installer and therefore you DON'T need to remove the installer.php)

It should be fixed, but it won't be easy and it won't be fast. If you want
to help - wonderful. But keep in mind that it will take months of wading
through the ugliest code we have in the tree. If you've got a weak stomach -
stay out. I've been there and it's not a nice place.

   - Al Viro

Harthas

  • Guest
Re: Admin-account insert failure
« Reply #3 on: April 05, 2008, 09:47:22 pm »
Thank you - I'll try as soon my server will be cured from his disease :-(

Harthas

  • Guest
Re: Admin-account insert failure
« Reply #4 on: April 05, 2008, 10:24:44 pm »
The licence-thingy now works fine, thank you.

But unfortunately the admin-account creation still doesn't work.
I tried several times, but everytime I click on Create (After I filled the form with Username Password Password), I just got a message because of a Major Security Issue (delete installer.php).

I downloaded the newest version out of the download-area, and updatet all the installer-files (installer.php and those in the lib/installer-folder).

MySQL Version is 5.0.51a , PHP 5.2.5

http://harthas.aufserver1.hieriminternet.de/nb/installer.php If you wanna try - dbconnect.php is already set, database is still empty.




Nightborn

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
  • Karma: +20/-0
    • View Profile
    • Shinobilegends
Re: Admin-account insert failure
« Reply #5 on: April 05, 2008, 10:28:18 pm »
remove your dbconnect.

and run again through the installer.

my wrong.

common.php, change this line to this:

259 } elseif ($logd_version == getsetting("installer_version","-1")  && file_exists('installer.php') && $_SERVER['SCRIPT_NAME']!="/installer.php") {

then try again.
It should be fixed, but it won't be easy and it won't be fast. If you want
to help - wonderful. But keep in mind that it will take months of wading
through the ugliest code we have in the tree. If you've got a weak stomach -
stay out. I've been there and it's not a nice place.

   - Al Viro

Harthas

  • Guest
Re: Admin-account insert failure
« Reply #6 on: April 05, 2008, 10:53:00 pm »
Well, it finally worked - But had to change your fix ;-9

Code: [Select]
} elseif ( ( $logd_version == getsetting( 'installer_version' , '-1' ) )  && file_exists( 'installer.php' ) && ( basename( $_SERVER['SCRIPT_NAME'] ) != 'installer.php' ) ) {
The problem was that $_SERVER['SCRIPT_NAME'] contained also the folder (/nb/installer.php), so it couldn't have worked. But for now, with basename, everything went smooth and fine. Probably you should/could change that too.

« Last Edit: April 05, 2008, 11:21:20 pm by Harthas »